Office 365 Mail (macOS Catalina Mail app) - Resolved/Monitoring
Incident Report for Duke IT
Resolved
If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Mar 25, 2020 - 15:12 EDT
Monitoring
Users of the macOS Catalina Mail app received an error message when attempting to connect to Duke's Office 365 mail system. OIT worked with the vendor to resolve the issue.

If you are still experiencing service issues please report those to the OIT Service Desk: https://oit.duke.edu/help
Posted Mar 25, 2020 - 10:21 EDT
This incident affected: Collaboration and Communication (Microsoft 365).