Canvas - Confirmed Service Issue

Incident Report for Duke IT

Resolved

Duke staff have monitored the service and can confirm that the issue with the enrollments in Canvas has been resolved.

If you are still experiencing service issues please send an email to canvas@duke.edu.
Posted May 16, 2025 - 14:48 EDT

Monitoring

Duke staff will continue to monitor the service but initial indications are that the issue with the enrollment feed for Canvas has been resolved.

If you are still experiencing service issues please send an email to canvas@duke.edu.
Posted May 16, 2025 - 13:43 EDT

Update

Duke staff are actively working with the vendor to confirm that the affected enrollments have been restored. We will provide an update as soon as we have it.
Posted May 16, 2025 - 09:51 EDT

Update

The vendor has begun to restore the affected enrollments. Users may notice certain courses re-appearing on their course dashboards over the next few hours.
Posted May 15, 2025 - 21:47 EDT

Update

Duke staff are still working with the vendor to restore service but there is no estimated time to resolution.
Posted May 15, 2025 - 16:38 EDT

Identified

Duke Learning Innovation has confirmed a service issue with Canvas. Users may not have access to their Spring and Summer courses due to an enrollment feed issue.

Duke staff are working to restore service but there is no estimated time to resolution.

If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.

For more information about Canvas visit the following web page: https://go.canvas.duke.edu/
Posted May 15, 2025 - 14:29 EDT
This incident affected: Other (Other) and Information Systems and Automation (DukeHub (PeopleSoft)).