AJO Web Site - Confirmed Service Issue

Incident Report for Duke IT

Monitoring

OIT will continue to monitor the service but initial indications are that the issue with the AJO web site has been resolved.

If you are still experiencing service issues please report those to the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Mar 29, 2025 - 08:07 EDT

Update

OIT staff are still working to restore service but there is no estimated time to resolution.
Posted Mar 27, 2025 - 14:31 EDT

Update

OIT staff are still working to restore service but there is no estimated time to resolution.
Posted Mar 26, 2025 - 15:10 EDT

Identified

OIT has confirmed a service issue with the AJO web site. Users cannot access academicjobsonline.org.

IT staff are working to restore service but there is no estimated time to resolution.

If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Mar 25, 2025 - 16:29 EDT
This incident affects: Other (Other).