OIT staff are still working with the vendor to restore service but there is no estimated time to resolution. OIT has confirmed that the issue is only impacting collaboration requests. All other outgoing messaging is functioning normally.
Posted May 30, 2025 - 10:30 EDT
Update
OIT staff are still working with the vendor to restore service but there is no estimated time to resolution.
Posted May 28, 2025 - 07:58 EDT
Update
OIT staff are still working with the vendor to restore service but there is no estimated time to resolution.
Posted May 23, 2025 - 14:46 EDT
Update
OIT has confirmed issues with Duke Qualtrics users sending collaboration invitations to external users, outside the Duke Qualtrics environment. Collaboration invitations may not have been received by their intended recipients. This issue does not appear to affect distributions. OIT staff are working with the vendor but there is not estimated time to resolution.
Posted May 21, 2025 - 11:51 EDT
Identified
OIT has confirmed a service issue with Qualtrics. Duke users may not be able to send collaboration invitations to external users, outside the Duke Qualtrics environment.
OIT staff are working with the vendor to restore service but there is no estimated time to resolution.
If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.