Concur (Travel and Expense Management) - Confirmed Service Issue
Incident Report for Duke IT
Resolved
The application owning group will continue to monitor the service but the vendor is reporting that the issue with Concur has been resolved.

If you are still experiencing service issues please report those to the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Mar 04, 2024 - 15:13 EST
Identified
Unfortunately the issue with expense reports and other functions within Concur persists. The vendor continues to work to restore service but there is no estimated time to resolution.
Posted Mar 04, 2024 - 13:16 EST
Monitoring
The application owning group will continue to monitor the service but initial indications are that the issue with Concur has been resolved.

If you are still experiencing service issues please report those to the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Mar 04, 2024 - 10:31 EST
Identified
The travel and expense management site, Concur, is currently unavailable.

IT staff are working with the vendor to restore service but there is no estimated time to resolution.

If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk (https://oit.duke.edu/help).

For more information about Concur visit the following web page: https://concur.duke.edu/expenses
Posted Mar 04, 2024 - 09:54 EST
This incident affected: Other (Other).