Central Campus - Power Outage
Incident Report for Duke IT
Resolved
This incident has been resolved.
Posted May 24, 2017 - 18:41 EDT
Identified
Most of Central Campus is currently experiencing a power outage.

Work is being done to restore power. If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help
Posted May 24, 2017 - 14:49 EDT
This incident affected: Other (Other).