Office 365 calendars published calendars showing incorrect times
Incident Report for Duke IT
Resolved
The issue with Office 365 calendars has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Nov 17, 2017 - 10:16 EST
Identified
There is evidence that a very small number of Office 365 calendars which have been "published" are displaying events in the incorrect time zone. The pages are showing entries 5 hours off schedule.

"Published" calendars can be accessed via URL without requiring an Office 365 account. Publishing requires specific actions be taken by the calendar owner. For this reason, most Office 365 calendars are not affected.

An incident has been opened with Microsoft and the issue is under investigation. There is no work-around option at this time.
Posted Nov 08, 2017 - 16:35 EST