OWA - Service Issue
Incident Report for Duke IT
Resolved
OIT has monitored the service and can confirm that the issue with OWA has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Aug 25, 2020 - 12:26 EDT
Monitoring
Microsoft has resolved this issue.

If you are still experiencing service issues please report those to the OIT Service Desk: https://oit.duke.edu/help
Posted Aug 22, 2020 - 11:16 EDT
Update
Microsoft continues to work on this issue and have stated they will provide an update on Saturday. As a reminder the following work around is available; after logging in change the URL to: https://outlook.office.com/mail/inbox
Posted Aug 21, 2020 - 07:49 EDT
Identified
The latest update from Microsoft states that the issue with OWA was not completely resolved as they had previously thought. They have deployed an emergency fix and expect the issue to be completely resolved by the end of the day (8/20).

If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help

For more information about OWA visit OIT's web page: https://oit.duke.edu/what-we-do/applications/office-365
Posted Aug 20, 2020 - 07:53 EDT
Monitoring
OIT will continue to monitor the service but initial indications are that the issue with OWA has been resolved.

If you are still experiencing service issues please report those to the OIT Service Desk: https://oit.duke.edu/help
Posted Aug 19, 2020 - 11:23 EDT
Update
Unfortunately this issue is still not resolved for all users. The vendor, Microsoft, continues to deploy a fix across the entire environment and we will provide an update when available.
Posted Aug 17, 2020 - 17:22 EDT
Update
Microsoft is deploying a fix for this issue and anticipates that the deployment will be completed by Monday.
Posted Aug 14, 2020 - 06:45 EDT
Update
A work around has been identified for this issue.

Upon login some users are being redirected to: https://outlook.office.com/owa

Users impacted by this issue, after logging in, should change the URL to: https://outlook.office.com/mail/inbox

Using that URL presents the full OWA client which is not impacted by this issue. Unfortunately the URL change is not persistent and may have to be done on every new login. If possible, bookmarking the above URL should help.

Microsoft continues to work on a permanent fix but there is still no estimated time to resolution.
Posted Aug 12, 2020 - 15:56 EDT
Update
Microsoft has identified a possible root cause to this issue but there is still no estimated time to resolution.
Posted Aug 12, 2020 - 10:09 EDT
Update
OIT staff continue to work with Microsoft in an attempt to restore service but there is still no estimated time to resolution.
Posted Aug 11, 2020 - 15:19 EDT
Update
OIT staff are still working with the vendor, Microsoft, to restore service but there is no estimated time to resolution.
Posted Aug 11, 2020 - 08:41 EDT
Identified
OIT has confirmed a service issue with OWA. Some users may experience issues with displaying/loading mailbox information.

OIT staff are working with the vendor, Microsoft, to restore service but there is no estimated time to resolution.

If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Aug 10, 2020 - 16:25 EDT
Investigating
OIT staff are currently investigating reports of service issues with OWA (Outlook on the web). Users may experience issues with displaying/loading mailbox information.

If you would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help

For more information about OWA visit OIT's web page: https://oit.duke.edu/what-we-do/applications/office-365
Posted Aug 10, 2020 - 15:27 EDT
This incident affected: Collaboration and Communication (Microsoft 365).