SSL Certificate Issuance - Service Issue
Incident Report for Duke IT
Resolved
OIT has monitored the service and can confirm that the issue with SSL certificate issuance has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Oct 14, 2019 - 11:52 EDT
Monitoring
OIT will continue to monitor the service but initial indications are that the issue with SSL certificate issuance has been resolved.

If you are still experiencing service issues please report those to the OIT Service Desk: https://oit.duke.edu/help
Posted Oct 14, 2019 - 09:41 EDT
Identified
OIT has confirmed a service issue with SSL certificate issuance.

OIT staff are working with the vendor to restore service but there is no anticipated time to resolution.

If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Oct 14, 2019 - 09:23 EDT
Investigating
OIT staff are currently investigating reports of service issues with SSL certificate issuance. Users may experience issuance failures via Locksmith and the vendor web interface. We will post additional details as they become available.

If you would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help

For more information about SSL certificates visit OIT's web page: https://oit.duke.edu/what-we-do/applications/ssl-certificate
Posted Oct 14, 2019 - 08:49 EDT
This incident affected: Security (Certificate Issuance).