Office 365 Personal Bookings - Confirmed Service Issue
Incident Report for Duke IT
Resolved
OIT has monitored the service and can confirm that the issue with Personal Bookings pages not loading in Office 365 Personal Bookings has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Jun 16, 2022 - 10:34 EDT
Monitoring
OIT will continue to monitor the service but initial indications are that the issue with Personal Bookings pages not loading in Office 365 Personal Bookings has been resolved.

If you are still experiencing service issues please report those to the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Jun 16, 2022 - 09:30 EDT
Update
OIT is still working with the vendor, Microsoft, on Personal Bookings pages not loading or displaying a 'This booking page has a new address' error. Unfortunately there is no estimated time to resolution.
Posted Jun 03, 2022 - 11:02 EDT
Update
OIT continues to work with the vendor, Microsoft, on Personal Bookings pages not loading or displaying a 'This booking page has a new address' error. Unfortunately there is still no estimated time to resolution.
Posted May 31, 2022 - 09:56 EDT
Update
OIT continues to work with the vendor, Microsoft, on Personal Bookings pages not loading or displaying a 'This booking page has a new address' error. Unfortunately there is still no estimated time to resolution.
Posted May 27, 2022 - 12:12 EDT
Identified
OIT has confirmed a service issue with Office 365 Personal Bookings. Personal Bookings pages aren't loading and may display a 'This booking page has a new address' error.

OIT staff are working with the vendor, Microsoft, to restore service but there is no estimated time to resolution.

If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.

For more information about Office 365 Personal Bookings visit OIT's web page: https://oit.duke.edu/help/articles/kb0033211
Posted May 26, 2022 - 15:19 EDT
This incident affected: Collaboration and Communication (Microsoft 365).