PHISHING ALERT
Incident Report for Duke IT
Resolved
This incident has been resolved.
Posted Mar 14, 2018 - 06:45 EDT
Monitoring
The Duke IT Security Office has received multiple reports of a widespread phishing attack. Visit the following page to view details of the phishing email: https://security.duke.edu/phish-20180313

If you have received the message, please delete without replying. If you have replied, please contact the OIT Service Desk at (919) 684-2200.
Posted Mar 13, 2018 - 17:18 EDT