Spok - Confirmed Service Issue

Incident Report for Duke IT

Resolved

DHTS has resolved the issue with direct dialing a paging number.
Posted Jun 23, 2025 - 10:57 EDT

Update

The issue with pagingweb.duke.edu has been resolved. DHTS is continuing to work on resolving the issue with direct dialing a paging number.
Posted Jun 23, 2025 - 09:56 EDT

Identified

DHTS has confirmed a service issue with Spok. Users cannot access the Spok web site, pagingweb.duke.edu, nor can they direct dial a paging number. This issue is not impacting the paging service itself, including pages from ServiceNow escalations.

DHTS staff are working to restore service but there is no estimated time to resolution.

For more information about Spok visit OIT's web page: https://duke.service-now.com/kb_view.do?sysparm_article=KB0026147
Posted Jun 23, 2025 - 08:48 EDT
This incident affected: Other (Other).