RightFax - Unavailable
Incident Report for Duke IT
Resolved
The issue with RightFax has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Aug 16, 2018 - 16:43 EDT
Identified
RightFax is intermittently unavailable for all users.

Technical staff are aware of the problem and are working to restore service. If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Aug 16, 2018 - 11:32 EDT
This incident affected: Other (Other).