OIT has monitored the service and can confirm that the issue with SSL certificate issuance has been resolved.
If you are still experiencing service issues please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted May 27, 2026 - 13:55 EDT
Monitoring
OIT will continue to monitor the service, but initial testing suggests that the issue affecting SSL certificate requests and issuance has been resolved. Certificate requests can now be successfully processed through both the Sectigo Certificate Manager and Locksmith.
If you are still experiencing service issues please report those to the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted May 27, 2026 - 11:17 EDT
Update
OIT has implemented a workaround that allows SSL certificate requests to be processed through Locksmith. However, SSL certificates still cannot be issued via the Sectigo Certificate Manager. Sectigo is actively working on a resolution but has not provided an updated timeframe.
Posted May 27, 2026 - 10:32 EDT
Update
SSL certificate requests remain unavailable through the Sectigo Certificate Manager and Locksmith. OIT expects to receive an update from Sectigo later today.
Posted May 27, 2026 - 07:19 EDT
Update
Unfortunately, the issue affecting SSL certificate issuance through both the Sectigo Certificate Manager and Locksmith persists. Sectigo has not provided an estimated time for resolution.
Posted May 26, 2026 - 19:47 EDT
Update
Sectigo continues to work on service restoration; however, there is still no estimated time for resolution. Due to this continuing issue, SSL certificate issuance remains unavailable through both the Sectigo Certificate Manager and Locksmith.
Posted May 26, 2026 - 14:09 EDT
Update
Sectigo is actively working to restore service; however, no estimated time for resolution has been provided. Due to this issue, SSL certificate issuance remains unavailable through both the Sectigo Certificate Manager and Locksmith.
Posted May 26, 2026 - 10:28 EDT
Identified
OIT has identified a service issue impacting SSL certificate issuance. Requests are currently failing through both the Sectigo Certificate Manager web interface and Locksmith, including ACME-based issuance.
A support case has been opened with Sectigo; however, an estimated time to resolution is not yet available.
If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.