Power Outage at Powerhouse, 300 Fuller, NC Mutual - Service Issue

Incident Report for Duke IT

Resolved

OIT has monitored the service and can confirm that the power outage at downtown locations of the Powerhouse, 300 Fuller and NC Mutual buildings. has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Jun 23, 2025 - 16:28 EDT

Monitoring

OIT will continue to monitor the service but initial indications are that power has been restored for the downtown locations of the Powerhouse, 300 Fuller and NC Mutual buildings.

If you are still experiencing service issues please report those to the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Jun 23, 2025 - 14:26 EDT

Identified

OIT has confirmed a power outage at downtown locations of the Powerhouse, 300 Fuller and NC Mutual buildings.

The power outage is part of a larger Duke Energy outage. Power is estimated to be restored by 3:30pm.
Posted Jun 23, 2025 - 13:26 EDT

Investigating

OIT staff are currently investigating reports of power outage at downtown locations of the Powerhouse, 300 Fuller and NC Mutual buildings.

FMD staff and management is on site investigating. We will post additional details as they become available.

If you would like to report additional service impacts please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Jun 23, 2025 - 13:16 EDT
This incident affected: Other (Other).