OIT has monitored the service and can confirm that the issue with email delivery has been resolved.
If you are still experiencing service issues please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Mar 19, 2025 - 08:22 EDT
Update
OIT staff are awaiting definitive confirmation from the vendor but our analysis shows that there have been no bounced emails for several hours. We will post additional information as soon as we received it from the vendor.
Posted Mar 18, 2025 - 16:28 EDT
Update
OIT staff are still working with the vendor to restore service but there is no estimated time to resolution.
Posted Mar 18, 2025 - 13:48 EDT
Identified
OIT has confirmed a service issue with email. Users may receive a 'bounced' notification when sending an email from their Duke email account to other Duke email addresses as well as non-Duke email addresses. Additionally, email being sent to your Duke email account from other Duke email addresses or non-Duke email addresses may bounce back to the sender.
If you receive a 'bounced' email message OIT is recommending that you try to resend the email.
OIT staff are working with the vendor to restore service but there is no estimated time to resolution.
If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Mar 18, 2025 - 10:10 EDT
This incident affected: Accounts and Email (Mail Transport and Routing).