Duke Health Network - Mail Delivery
Incident Report for Duke IT
Resolved
The issue with the Duke Health network has been resolved and mail delivery has normalized.
Posted Mar 21, 2017 - 15:23 EDT
Identified
Duke Health is experiencing issues with their network which is preventing mail delivery to @mc.duke.edu and is also preventing Duke Health Office 365 users from being able to send email to external, non Duke addresses. Email delivery to @duke.edu addresses internal to Office 365 is not impacted.
Posted Mar 21, 2017 - 10:09 EDT
This incident affected: Accounts and Email (Mail Transport and Routing).