OIT has monitored the service and can confirm that the issue with Duke Hub has been resolved.
If you are still experiencing service issues please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Apr 13, 2025 - 16:58 EDT
Monitoring
OIT will continue to monitor the service but initial indications are that the issue with Duke Hub has been resolved.
If you are still experiencing service issues please report those to the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Apr 13, 2025 - 14:40 EDT
Identified
OIT has confirmed a service issue with Duke Hub. Users cannot access Duke Hub and are redirected to an alert page.
OIT staff are working to restore service but there is no estimated time to resolution.
If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
For more information about Duke Hub visit OIT's web page: dukehub.duke.edu
Posted Apr 13, 2025 - 10:37 EDT
This incident affected: Information Systems and Automation (DukeHub (PeopleSoft)).