Mail Delivery Delays - Possible Service Issue
Incident Report for Duke IT
Resolved
OIT has monitored the service and there have been no additional reports of issues.

If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Dec 10, 2018 - 12:48 EST
Monitoring
OIT was unable to find a system wide issue with mail delivery. There were some reports from Outlook client users of delays with email leaving the Outbox. If you experience this issue it is recommended that you restart Outlook and try again.

If service issues continue please report those to the OIT Service Desk: https://oit.duke.edu/help
Posted Dec 10, 2018 - 10:20 EST
Investigating
OIT staff are currently investigating reports of service issues with mail delivery. We will post additional details as they become available.

If you would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help

For more information about email visit OIT's web page: https://oit.duke.edu/what-we-do/applications/office-365
Posted Dec 10, 2018 - 09:21 EST
This incident affected: Accounts and Email (Mail Transport and Routing).