OIT has continued monitoring the service and confirms that the Hyper‑V virtual server hosting environment is stable, with no additional issues observed.
If you are still experiencing service issues please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted May 18, 2026 - 10:44 EDT
Update
OIT continues to monitor the Hyper-V environment to ensure stability. No additional service-impacting incidents have been reported since yesterday.
Posted May 15, 2026 - 12:04 EDT
Monitoring
OIT will continue to monitor the service but initial indications are that the issue with HyperV has been resolved.
If you are still experiencing service issues please report those to the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted May 14, 2026 - 15:49 EDT
Identified
OIT has confirmed a service issue with HyperV. Another issue has occurred and users may not be able to access HyperV machines in the Telcom data center.
OIT staff are working to restore service but there is no estimated time to resolution.
If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted May 14, 2026 - 14:13 EDT
Monitoring
OIT will continue to monitor the service but initial indications are that the issue with HyperV has been resolved.
If you are still experiencing service issues please report those to the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted May 14, 2026 - 13:10 EDT
Identified
OIT has confirmed a service issue with HyperV. Users might not be able to access the Hyper-V machines in the Telcom data center.
OIT staff are working to restore service but there is no estimated time to resolution.
If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted May 14, 2026 - 10:42 EDT
This incident affected: Virtualization and Storage (Virtual Server Hosting).