Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 22, 2025 - 21:00 EDT
Scheduled
The locations listed below have Network maintenance scheduled. There will be a 10-15 minute loss of network and voice connectivity during the maintenance window.
1013 Broad 1515 Hull 1517 Hull 300 Alexander 300 Fuller 300 Swift 306 Alexander 402 Oregon 406 Oregon 406 Swift 614 Chapel Dr 705 Broad Academic Advising Allen Alspaugh Alumni Arts ATC Lucky Strike Baldwin Baseball Stadium Bassett Bell Tower Bevans Biddle Bio Sci Bishop Bivins Blackwell Bostock Branson Bridges Brightleaf Brodie Brown Bryan Center Campus Drive Engineering Building
If you have any questions about the maintenance or if you experience an unexpected service impact please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Jun 18, 2025 - 10:20 EDT
This scheduled maintenance affected: Wireless and Wired Connectivity (West Campus Buildings, Central Campus Buildings, East Campus Buildings, West Campus Residence Halls, Central Campus Residence Halls, East Campus Residence Halls).