OIT has monitored the service and can confirm that the issue with email delivery delays from Duke email addresses to non-Duke email addresses has been resolved.
If you are still experiencing service issues please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Feb 14, 2025 - 10:56 EST
Monitoring
OIT will continue to monitor the service but initial indications are that the issue with email delivery delays from Duke email addresses to non-Duke email addresses has been resolved.
If you are still experiencing service issues please report those to the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Feb 14, 2025 - 09:41 EST
Update
OIT will implement an emergency change this evening at 8 pm that should improve the delivery delays from Duke email addresses to non-Duke email addresses.
Posted Feb 13, 2025 - 13:43 EST
Identified
OIT has confirmed delays in outbound email delivery. Users may experience email delivery delays from Duke email addresses to non-Duke email addresses.
OIT staff are working with the vendor to fully restore service but there is no estimated time to resolution.
If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.