OIT has monitored the service and can confirm that the issue with email delivery delays has been resolved.
If you are still experiencing service issues please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Feb 11, 2025 - 12:23 EST
Monitoring
OIT will continue to monitor the service but initial indications are that the issue with email delivery delays has been resolved.
If you are still experiencing service issues please report those to the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Feb 11, 2025 - 07:16 EST
Update
OIT is still working to resolve the email delivery delays.
Posted Feb 11, 2025 - 05:21 EST
Identified
OIT has confirmed a service issue with email. Users may see a delay in email received.
If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Feb 10, 2025 - 22:40 EST
This incident affected: Other (Other) and Accounts and Email (Mail Transport and Routing).