Account Self-Service - Service Issue
Incident Report for Duke IT
Resolved
OIT has monitored the service and can confirm that the issue with Account Self-Service has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Feb 16, 2020 - 10:06 EST
Update
We are continuing to monitor for any further issues.
Posted Feb 16, 2020 - 09:07 EST
Monitoring
OIT will continue to monitor the service but initial indications are that the issue with Account Self-Service has been resolved.

If you are still experiencing service issues please report those to the OIT Service Desk: https://oit.duke.edu/help
Posted Feb 16, 2020 - 08:06 EST
Investigating
OIT staff are currently investigating reports of service issues with Account Self-Service. We will post additional details as they become available.

If you would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help

For more information about Account Self-Service visit OIT's web page: https://oit.duke.edu/what-we-do/applications/account-self-service
Posted Feb 16, 2020 - 07:50 EST
This incident affected: Accounts and Email (Self Service Tools).