MS Bookings - Confirmed Service Issue

Incident Report for Duke IT

Update

Microsoft is still working to restore service but there is no estimated time to resolution.
Posted May 29, 2026 - 14:29 EDT

Identified

OIT has confirmed a service issue with MS Bookings. Published Microsoft Bookings links are returning as invalid when users attempt to access them. If you experience this issue, locate the event type, click the three dots next to the share icon, and select duplicate. The duplicate link has worked for some users.

OIT staff are working with the vendor to restore service but there is no estimated time to resolution.

If you have questions about this outage or would like to report additional service impacts, please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.

For more information about MS Bookings visit OIT's web page: https://oit.duke.edu/help/articles/kb0031685/
Posted May 28, 2026 - 14:43 EDT
This incident affects: Other (Other).