Duo - Confirmed Service Issue

Incident Report for Duke IT

Resolved

The vendor, Duo, has monitored the service and can confirm that the issue with multi-factor authentication via SMS or phone call has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Feb 14, 2025 - 07:57 EST

Monitoring

The vendor, Duo, will continue to monitor the service but initial indications are that the issue with multi-factor authentication via SMS or phone call has been resolved.

If you are still experiencing service issues please report those to the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Feb 14, 2025 - 05:32 EST

Identified

The vendor has confirmed a service issue with Duo. Users may not be able to use Duo for multi-factor authentication via SMS or phone call: https://status.duo.com/incidents/h7lht3g1zv9w

If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.

For more information about Duo visit OIT's web page: https://oit.duke.edu/service/duo/
Posted Feb 13, 2025 - 14:31 EST
This incident affected: Security (Multi-Factor Authentication).