Karsh Alumni Building - Network Outage

Incident Report for Duke IT

Resolved

Network connectivity at Karsh Alumni Building has been restored.

If you are still experiencing service issues please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Sep 24, 2026 - 08:30 EDT

Investigating

Network connectivity is currently unavailable at Karsh Alumni Building due to ongoing power work. Estimated time of restoration is 8:30AM.

OIT will provide updates as they become available.

If you would like to report additional service impacts please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Sep 24, 2026 - 07:25 EDT
This incident affected: Wireless and Wired Connectivity (East Campus Buildings).