Microsoft resumed accepting email shortly after 10:00 PM last night. Although the message backlog took several hours to process, service is now stabilizing.
OIT will provide an update later in the morning.
If you are still experiencing service issues please report those to the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Jan 23, 2026 - 05:24 EST
Update
Microsoft has identified a portion of service infrastructure in the North America region that is not processing traffic as expected. This is impacting load balancing processes and general service availability. They are working to restore this infrastructure to a heathy state and rebalance the service traffic to achieve recovery.
Internal Duke to Duke email does not currently appear to be impacted.
Posted Jan 22, 2026 - 15:43 EST
Identified
OIT has confirmed a service issue with Microsoft 365. Users may see issues with email delivery, MS Purview admin center, and Microsoft Defender.
OIT staff are working with the vendor to restore service but there is no estimated time to resolution.
If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.