Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 23, 2025 - 21:00 EDT
Scheduled
The locations listed below have Network maintenance scheduled. There will be a 10-15 minute loss of network and voice connectivity during the maintenance window.
Cameron Card Gymnasium Carpentry Shop Center Athletic Excellence Chapel Dr Chesterfield Child Care Chiller 3 Ciemas Classroom Craven Credit Union Crowell Devil's Den Doris Duke Center Duke Gardens Duke Stores DUMAC DUML East Campus Service Facility East Duke East Residence Hall East Union Edens Epworth Erwin Mill Erwin Tower Faculty Club Grainger One City Center Smart House
If you have any questions about the maintenance or if you experience an unexpected service impact please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Jun 18, 2025 - 10:22 EDT
This scheduled maintenance affected: Wireless and Wired Connectivity (West Campus Buildings, Central Campus Buildings, East Campus Buildings, West Campus Residence Halls, Central Campus Residence Halls, East Campus Residence Halls).