OWA (mail.duke.edu) - Confirmed Service Issue

Incident Report for Duke IT

Resolved

OIT has monitored the service and can confirm that the issue with OWA (mail.duke.edu) has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Apr 15, 2025 - 19:01 EDT

Monitoring

OIT will continue to monitor the service but initial indications from the vendor, Microsoft, are that the issue with OWA (mail.duke.edu) has been resolved.

If you are still experiencing service issues please report those to the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Apr 15, 2025 - 16:58 EDT

Identified

OIT has confirmed a service issue with OWA (mail.duke.edu). Some users may be unable to access their mailboxes through mail.duke.edu.

OIT staff are working with the vendor to restore service but there is no estimated time to resolution.

If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.

For more information about OWA (mail.duke.edu) visit OIT's web page: https://oit.duke.edu/service/microsoft-365-formerly-office-365/
Posted Apr 15, 2025 - 13:30 EDT
This incident affected: Collaboration and Communication (Microsoft 365).