Kuali Build - Confirmed Service Issue

Incident Report for Duke IT

Resolved

The vendor has confirmed that the issue has been resolved, and the service is now operating normally.

If you are still experiencing service issues please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Jul 07, 2026 - 22:09 EDT

Identified

OIT has confirmed a service issue with Kuali Build. Users are currently unable to access the system or perform their work in Kuali Build. The vendor is aware of the issue and is actively working to resolve it.

If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.

For more information about Kuali Build visit OIT's web page: https://oit.duke.edu/service/kuali-build/
Posted Jul 07, 2026 - 21:43 EDT
This incident affected: Other (Other).