Power Outage - Central Campus - Confirmed Service Issue
Incident Report for Duke IT
Resolved
The power outage affecting Central Campus has been resolved. Power has been restored to the affected locations.

If you are still experiencing service issues please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted May 14, 2023 - 16:44 EDT
Monitoring
Duke Energy is reporting that power has been restored to Central Campus. We will continue to monitor in the event there are other issues.

If you are still experiencing service issues please report those to the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted May 14, 2023 - 14:05 EDT
Identified
Duke Energy is reporting a power outage that is affecting Central Campus. Power is expected to be restored by 5:15pm today. The outage is affecting the following locations: 300 Swift Ave, 406-408 Swift Ave, Swift Apartments, 1515-1516 Hull Ave.

If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted May 14, 2023 - 13:39 EDT
This incident affected: Wireless and Wired Connectivity (Central Campus Buildings, Central Campus Residence Halls).