Email Delivery - Confirmed Service Issue
Incident Report for Duke IT
Resolved
Microsoft completed an investigation into this issue and they determined that there was actually no service impact to email delivery.

If you experience service issues please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Mar 13, 2024 - 17:50 EDT
Identified
Microsoft has confirmed a service issue with email delivery. Email messages maybe delayed by two hours and some email messages maybe rejected for delivery. If an email is rejected for delivery the sender will receive a notice.

The vendor, Microsoft, is working to restore service but there is no estimated time to resolution.

If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.

For more information about email visit OIT's web page: https://oit.duke.edu/service/email-and-calendar/
Posted Mar 13, 2024 - 14:09 EDT
This incident affected: Accounts and Email (Mail Transport and Routing).