SSL Certificate Issuance - Confirmed Service Issue
Incident Report for Duke IT
Resolved
OIT has monitored the service and can confirm that the issue with SSL certificate issuance has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Jul 26, 2024 - 14:55 EDT
Monitoring
OIT will continue to monitor the service but initial indications are that the issue with SSL certificate issuance has been resolved.

If you are still experiencing service issues please report those to the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Jul 26, 2024 - 13:56 EDT
Identified
OIT has confirmed a service issue with SSL certificate issuance. Users may experience SSL certificate issuance delays via Locksmith and the Sectigo Certificate Manager interface.

The vendor, Sectigo, is working to restore service but there is no estimated time to resolution.

If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.

For more information about SSL certificates visit OIT's web page: https://oit.duke.edu/service/ssl-certificate/
Posted Jul 26, 2024 - 09:31 EDT
This incident affected: Security (Certificate Issuance).