Box.com - Service Issue

Incident Report for Duke IT

Resolved

OIT has monitored the service and can confirm that the issue with Box and MS Office online files has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Mar 12, 2025 - 09:27 EDT

Monitoring

The vendor has confirmed a service issue with Box and MS Office online files but they have taken steps to remediate the problem. The issue was that users may have seen errors or slowness when attempting to open MS Office files through MS Office Online via Box.

Vendor Status Page: https://status.box.com/incidents/54k4mwdqpvr0

If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.
Posted Mar 12, 2025 - 08:51 EDT

Investigating

OIT staff are currently investigating reports of service issues with Box.com

We will post additional details as they become available.

If you would like to report additional service impacts please contact the OIT Service Desk (https://oit.duke.edu/help) or join the conversation on the 'University IT Outage Communication' MS Teams site.

For more information about Box.com visit OIT's web page: https://oit.duke.edu/
Posted Mar 12, 2025 - 08:06 EDT
This incident affected: Collaboration and Communication (Duke Box).