Office 365 - Email delivery delays
Incident Report for Duke IT
Resolved
The issue with Office 365 email delivery delays has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Feb 27, 2018 - 14:02 EST
Identified
Office 365 is degraded for all users. Inbound mail and mailing lists are experiencing sporadic delays of up to 20 minutes. Outbound mail is not impacted.

OIT staff are aware of the problem and are working with the vendor to restore service. If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help

For more information about Office 365 visit OIT's web page: https://oit.duke.edu/what-we-do/applications/office-365
Posted Feb 22, 2018 - 13:59 EST
This incident affected: Collaboration and Communication (Microsoft 365).