Office 365 - Inbound Mail Delivery issues
Incident Report for Duke IT
Resolved
The inbound mail delivery issue has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Feb 10, 2017 - 14:35 EST
Identified
OIT is aware of and investigating issues with inbound mail delivery from external sources.

OIT staff are aware of the problem and are working to restore service. If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help

For more information about Office 365 visit OIT's web page: https://oit.duke.edu/what-we-do/applications/office-365
Posted Feb 10, 2017 - 12:14 EST
This incident affected: Collaboration and Communication (Microsoft 365).