Duo Phone Call Authentication - Confirmed Service Issue
Incident Report for Duke IT
Resolved
OIT has monitored the service and can confirm that the issue with Duo phone call authentication has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Nov 07, 2019 - 18:21 EST
Monitoring
OIT will continue to monitor the service but initial indications are that the issue with Duo phone call authentication has been resolved.

If you are still experiencing service issues please report those to the OIT Service Desk: https://oit.duke.edu/help
Posted Nov 07, 2019 - 16:02 EST
Update
The vendor is still working to restore service but there is no estimated time to resolution.
Posted Nov 07, 2019 - 14:39 EST
Identified
The vendor has confirmed a service issue with Duo phone call authentication.

The vendor is working to restore service but there is no estimated time to resolution.

If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help

For more information about Duo visit OIT's web page: https://oit.duke.edu/what-we-do/applications/duo
Posted Nov 07, 2019 - 12:50 EST
This incident affected: Security (Multi-Factor Authentication).