Self Service Tools - Password change delays
Incident Report for Duke IT
Resolved
OIT has monitored the service and can confirm that the issue with Self Service Tools has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Sep 24, 2020 - 17:04 EDT
Monitoring
OIT will continue to monitor the service but initial indications are that the issue with Self Service Tools has been resolved.

If you are still experiencing service issues please report those to the OIT Service Desk: https://oit.duke.edu/help
Posted Sep 24, 2020 - 16:38 EDT
Identified
OIT has confirmed a service issue with Self Service Tools password changes. Duke Health users are able to change their passwords, but may experience problems logging into different applications due to issues with back end syncing.

OIT staff are working to restore service but there is no estimated time to resolution.

If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help

For more information about Self Service Tools visit: https://oit.duke.edu/what-we-do/services/self-service-tools
Posted Sep 24, 2020 - 15:38 EDT
This incident affected: Accounts and Email (Self Service Tools, Service Desk Utilities).