Finesse - Login Issues
Incident Report for Duke IT
Resolved
The issue with Finesse has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted 13 days ago. Sep 12, 2017 - 10:43 EDT
Identified
Agents are experiencing issues logging into Finesse. Agents who were already logged into Finesse are still available to receive calls.

OIT staff are aware of the problem and are working to restore service. If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help

For more information about Finesse visit OIT's web page: https://oit.duke.edu/what-we-do/applications/finesse-agent-login-tool
Posted 13 days ago. Sep 12, 2017 - 10:27 EDT
This incident affected: Collaboration and Communication (Call Center Services).