Office 365 Calendar - Confirmed Service Issue
Incident Report for Duke IT
Resolved
OIT has monitored the service and can confirm that the issue with Office 365 calendar has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Jan 31, 2020 - 17:28 EST
Update
The vendor, Microsoft, is deploying a fix which will resolve this issue by Friday.
Posted Jan 29, 2020 - 15:03 EST
Update
The vendor, Microsoft, has begun to deploy a fix which they hope will correct the issue. We anticipate receiving a possible resolution timeline tomorrow.
Posted Jan 28, 2020 - 15:10 EST
Identified
OIT has confirmed a service issue with Office 365 calendar. A small number of users may intermittently be unable to update calendar meetings.

The vendor, Microsoft, is working to restore service but there is no estimated time to resolution.

If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help

For more information about Office 365 calendar please visit OIT's web page: https://oit.duke.edu/what-we-do/applications/office-365
Posted Jan 27, 2020 - 17:45 EST
This incident affected: Collaboration and Communication (Microsoft 365).