Mail Delivery Delays
Incident Report for Duke IT
Resolved
The issue with mail delivery delays has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted 15 days ago. Nov 06, 2018 - 06:40 EST
Identified
Email messages sent from the Duke mail system to non-Duke email addresses, as well as email sent through Duke mailing lists, are experiencing delivery delays.

If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help
Posted 16 days ago. Nov 05, 2018 - 14:48 EST
This incident affected: Accounts and Email (Mail Transport and Routing).