Comodo SSL Certificate Issuance Delays
Incident Report for Duke IT
Resolved
The issue with Comodo SSL Certificate issuance delays has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted 4 months ago. Aug 09, 2018 - 19:40 EDT
Identified
Comodo, the vendor used to provide SSL certificates, is experiencing a technical issue that is delaying the issuance of new SSL certificates. This does not impact already issued SSL certificates.

The vendor is aware of the problem and is working towards a resolution. If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help

For more information about SSL certificates visit OIT's web page: https://oit.duke.edu/what-we-do/applications/ssl-certificate
Posted 4 months ago. Aug 09, 2018 - 15:05 EDT
This incident affected: Other (Other).