Crowell Building - Network Issue
Incident Report for Duke IT
Resolved
The internet issue was due to a power outage. Power has been restored and internet is available.
Posted Nov 10, 2018 - 19:23 EST
Investigating
OIT staff are currently investigating reports of network issues within Crowell Building. We will post additional details as they become available.

If you would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Nov 10, 2018 - 19:18 EST
This incident affected: Other (Other).