Sign in error with Acrobat Pro DC
Incident Report for Duke IT
Resolved
The issue with Adobe has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Oct 19, 2018 - 06:42 EDT
Monitoring
Users may see an error: "Please connect to the Internet and Retry" when signing into Acrobat Pro DC. An active ticket with the vendor is currently open. There is no ETA.
Posted Oct 17, 2018 - 16:58 EDT
This incident affected: Other (Other).