SPOK Paging - Paging Delays
Incident Report for Duke IT
Resolved
The issue with SPOK physical pagers has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Jun 11, 2019 - 18:42 EDT
Identified
SPOK paging is currently experiencing issues with physical pagers. Pages are processing but are delayed. The Spok Mobile, Paging web, and Email2Page services are not affected.

The vendor is working to restore service but there is no estimated time to resolution.

If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Jun 11, 2019 - 11:06 EDT
This incident affected: Other (Other).