API Healthcare (Time and Attendance) - Possible Service Issue
Incident Report for Duke IT
Resolved
The issue with API Healthcare (Time and Attendance) has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Sep 05, 2018 - 07:48 EDT
Investigating
Financial Services staff are currently investigating reports of service issues with API Healthcare (Time and Attendance). We will post additional details as they become available.

If you would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Sep 05, 2018 - 07:05 EDT
This incident affected: Information Systems and Automation (API Healthcare).