Office 365 Distribution Group Management - Confirmed Service Issue
Incident Report for Duke IT
Resolved
OIT has monitored the service and can confirm that the issue with Distribution Groups has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Mar 30, 2020 - 06:31 EDT
Monitoring
OIT will continue to monitor the service but initial indications are that the issue with management of Distribution Groups has been resolved.

If you are still experiencing service issues please report those to the OIT Service Desk: https://oit.duke.edu/help
Posted Mar 27, 2020 - 12:14 EDT
Update
The vendor, Microsoft, is still working to restore service but there is no estimated time to resolution.

If you experience this issue an available workaround is to use the Windows Outlook client:

https://duke.service-now.com/kb_view.do?sysparm_article=KB0032715
Posted Mar 24, 2020 - 11:21 EDT
Identified
OIT has confirmed a service issue with Office 365.

Management of Distribution Group membership is currently unavailable in Outlook on the Web (OWA). This does not affect mail to and from distribution groups.

OIT staff are working with the vendor to restore service, but there is no estimated time to resolution.

If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Mar 23, 2020 - 11:31 EDT
This incident affected: Collaboration and Communication (Microsoft 365).