Call Center Services - Degraded
Incident Report for Duke IT
Resolved
The issue with Call Center Services has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted 2 months ago. Aug 09, 2018 - 11:59 EDT
Identified
Call Center Services is degraded for all users.

OIT staff are aware of the problem and are working to restore service. If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help

For more information about Call Center Services visit OIT's web page: https://oit.duke.edu/what-we-do/services/call-center-services
Posted 2 months ago. Aug 09, 2018 - 11:27 EDT
This incident affected: Collaboration and Communication (Call Center Services).