Duke Box (Box.com) - Unavailable
Incident Report for Duke IT
Resolved
The issue with Duke Box (Box.com) has been resolved.

If you are still experiencing service issues please contact the OIT Service Desk: https://oit.duke.edu/help
Posted Oct 21, 2016 - 08:36 EDT
Identified
Duke Box (Box.com) is unavailable for all users.

OIT staff are aware of the problem and are working to restore service. If you have questions about this outage or would like to report additional service impacts please contact the OIT Service Desk: https://oit.duke.edu/help

For more information about Duke Box visit OIT's web page: https://oit.duke.edu/what-we-do/applications/duke-box
Posted Oct 21, 2016 - 08:10 EDT
This incident affected: Collaboration and Communication (Duke Box).